Microsoft Azure Incident in West Europe: Delayed Cluster Operations
Incident Report for MongoDB Cloud
Resolved
The issue has been resolved, and the system is now operating as expected.
Posted Mar 26, 2024 - 11:54 UTC
Identified
Microsoft Azure is experiencing an issue with the Azure Resource Manager in the West Europe region. As a result, users may experience delays creating, updating or deleting clusters in this region.

Further incident details may be found in the Service Health Dashboard in your Microsoft Azure Portal.
Posted Mar 26, 2024 - 03:56 UTC
This incident affected: MongoDB Cloud.