Serverless and Flex Upgrades Failing

Incident Report for MongoDB Cloud

Resolved

This incident has been resolved.
Posted Jul 12, 2025 - 01:08 UTC

Monitoring

We've merged a code fix and deployed it to production. We are monitoring serverless and flex upgrades to confirm resolution
Posted Jul 12, 2025 - 00:59 UTC

Identified

We've identified an issue where serverless and flex upgrades are failing at an elevated rate. We've identified the root cause and are implementing a fix.
Posted Jul 12, 2025 - 00:16 UTC
This incident affected: MongoDB Cloud.