Partial outage in Azure West Europe

Incident Report for MongoDB Cloud

Monitoring

We're starting to see instances recover. We will continue to monitor the region's status in Azure and ensure Atlas takes any available steps to maintain cluster health.
Posted May 03, 2026 - 20:19 UTC

Investigating

We are observing widespread issues in in Azure West Europe. Customers may see nodes reporting as "down" and delayed cluster modifications for Azure clusters in West Europe. There are three total AZs in Azure West Europe, and primary failover will be handled by MongoDB.
Posted May 03, 2026 - 17:33 UTC
This incident affects: MongoDB Cloud.