MongoDB Atlas: Cluster creation, deletion, and modification delayed
Incident Report for MongoDB Cloud
Resolved
This issue has been resolved.
Posted Jan 18, 2024 - 00:05 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 16, 2024 - 20:39 UTC
Identified
We have identified an issue delaying certain cluster modifications. Specifically, creating, deleting, modifying the count of nodes in a cluster, or certain maintenance operations that may do these things is presently delayed.

MongoDB operations on clusters, as well as cluster health is unaffected.
Posted Jan 16, 2024 - 18:03 UTC
This incident affected: MongoDB Cloud.