MongoDB Atlas: M0, M2, M5, Serverless, and Flex tier cluster changes delayed

Incident Report for MongoDB Cloud

Resolved

This incident has been resolved.
Posted Mar 20, 2025 - 21:12 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 20, 2025 - 21:04 UTC

Update

We have identified an issue making cluster configuration changes to M0/M2/M5, Flex, and Serverless clusters. Affected Projects will see the "blue bar" for an extended period of time. This is also impacting the creation of new clusters of those types as well as restores to them.

Clusters without changes pending are not affected.
Posted Mar 20, 2025 - 19:12 UTC

Identified

We have identified an issue modifying IP access lists for M0/M2/M5, Flex, and Serverless clusters. Affected Projects will see the "blue bar" for an extended period of time. Clusters without changes pending are not affected.
Posted Mar 20, 2025 - 19:08 UTC
This incident affected: MongoDB Cloud.