AWS Cluster DNS Changes Degraded Performance

Incident Report for MongoDB Cloud

Resolved

DNS updates for ACME are confirmed healthy. Cluster updates are now proceeding as expected.
Posted May 07, 2026 - 22:15 UTC

Update

We are continuing to monitor for any further issues.
Posted May 07, 2026 - 19:47 UTC

Monitoring

We've identified a bad piece of metadata causing DNS issues. We've since patched this metadata and are seeing recovery in ACME updates for cluster topology changes. We will continue to monitor recovery.
Posted May 07, 2026 - 19:47 UTC

Investigating

We are still seeing cases where new cluster update requests are failing to go through due to ACME related DNS issues. We are actively investigating this issue.
Posted May 07, 2026 - 17:50 UTC

Update

Mitigation is in progress; recovery for DNS operations and downstream cluster topology changes has begun.
Posted May 07, 2026 - 16:58 UTC

Update

DNS changes for AWS clusters are currently degraded. Cluster topology modifications may be delayed or not able to complete successfully. We've identified the issue and are pushing out a patch.
Posted May 07, 2026 - 15:20 UTC

Identified

DNS changes for AWS clusters are currently degraded. We've identified the issue and are pushing out a patch.
Posted May 07, 2026 - 15:17 UTC
This incident affected: MongoDB Atlas for Government.