Overly frequent maintenance notifications

Incident Report for MongoDB Cloud

Resolved

We have remediated the issue causing overly frequent maintenance notifications.
Posted Jun 11, 2025 - 21:46 UTC

Identified

We've identified an issue where the system will send maintenance notifications too frequently. Cluster health is unaffected. We're actively working to remediate the situation
Posted Jun 11, 2025 - 20:22 UTC
This incident affected: MongoDB Cloud.