MongoDB Support Portal - Redirect Issues
Incident Report for MongoDB Cloud
Resolved
The [MongoDB Support Portal](https://support.mongodb.com/) was experiencing some redirect issues on existing cases due to incorrect configuration deployment between 2020-03-25 05:21 PM (in UTC) and 2020-03-25 06:53 PM (in UTC). This issue has been resolved.
Please refresh your browser and/or clear your browser cache before logging into the MongoDB Support Portal.
Posted Mar 25, 2020 - 20:13 UTC
Investigating
The MongoDB Support Portal is experiencing some redirect issues on existing, open cases. If you require assistance with a critical MongoDB Technical Support issue, please contact us by phone.
Posted Mar 25, 2020 - 18:46 UTC
This incident affected: MongoDB Support Portal.