Elevated LetsEncrypt Errors causing Delayed Cluster Modifications

Incident Report for MongoDB Cloud

Resolved

This incident has been resolved.
Posted Aug 05, 2025 - 21:29 UTC

Monitoring

We've implemented a fix and are monitoring the situation
Posted Aug 05, 2025 - 20:55 UTC

Identified

We are investigating elevated errors from our certificate authority provider LetsEncrypt. Customers may see delayed cluster modifications and failed snapshot restores. We are working on a mitigation.
Posted Aug 05, 2025 - 20:04 UTC
This incident affected: MongoDB Cloud.