MongoDB Atlas: Data explorer operations fail with a timeout error

Incident Report for MongoDB Cloud

Resolved

This incident has been resolved.
Posted Jul 08, 2025 - 18:42 UTC

Update

At this time, the impact is limited to Projects with the "New Data Explorer Preview" setting active. Users can switch their Data Explorer Preview off at the Project's Settings page to regain use of the Data Explorer.

Cluster health is unaffected.
Posted Jul 08, 2025 - 18:30 UTC

Identified

We have identified an issue affecting MongoDB Atlas's Data Explorer functionality. Affected users may see a timeout error when trying to read or write data via the Data Explorer.

Underlying cluster health is unaffected. As a workaround, we would suggest users use MongoDB Compass or other standalone MongoDB-compatible data reading apps on their own machines.
Posted Jul 08, 2025 - 18:03 UTC
This incident affected: MongoDB Cloud.