According to AWS, two Availability Zones in me-central-1 (UAE) and one Availability Zone in me-south-1 (Bahrain) are now experiencing outages. This increases the scope of the underlying infrastructure incident in these regions. The latest information from AWS is available at https://health.aws.amazon.com/health/status.
CURRENT IMPACT Atlas clusters deployed only in me-central-1 may now be fully unavailable. For these clusters operating solely in me-central-1, backup operations in this region are impaired. Backups should remain operational in me-south-1 at this time. We do not yet have an ETA from AWS for full restoration of service in the impacted Regions and Availability Zones.
RECOMMENDED CUSTOMER ACTIONS If you have a multi-region configuration that includes a healthy secondary region, we recommend routing application traffic to that secondary region. If you have clusters in me-south-1 taking backups, we recommend enabling "Additional Snapshot Copies Policy" to a different region. If you have time-sensitive production changes or operations that are blocked and need urgent assistance, please contact MongoDB Support via the Support Portal, Support Chat or in-product support.
WHAT WE ARE DOING We recognize the severity of this situation and the impact it may have on your workloads. The incident continues to evolve, and we are closely monitoring AWS status and regional health signals. We are validating Atlas behavior across affected and unaffected regions, and working to mitigate customer impact where possible. We will provide further updates as soon as we have materially new information.
Posted Mar 02, 2026 - 09:20 UTC
Update
Update: We are continuing to monitor an ongoing issue in AWS me-central-1 (United Arab Emirates) caused by an underlying AWS infrastructure disruption isolated to a single Availability Zone. Please visit the AWS Health Dashboard for detailed information on the Availability Zone outage (https://health.aws.amazon.com/health/status).
If you have time-sensitive changes that are blocked and need urgent assistance, please contact MongoDB Support.
Posted Mar 02, 2026 - 02:17 UTC
Update
Update: We are continuing to monitor an ongoing issue in AWS me-central-1 (United Arab Emirates) caused by an underlying AWS infrastructure disruption isolated to a single Availability Zone. Please visit the AWS Health Dashboard for detailed information on the Availability Zone outage (https://health.aws.amazon.com/health/status).
If you have time-sensitive changes that are blocked and need urgent assistance, please contact MongoDB Support.
Posted Mar 01, 2026 - 19:30 UTC
Update
Update: One or more instances backing MongoDB Atlas clusters in the AWS ME-CENTRAL-1 (United Arab Emirates) region may have been temporarily unavailable due to an underlying AWS issue in a single Availability Zone . According to AWS, a localized power issue in this Availability Zone has affected connectivity and power for some APIs and instances, and may have caused increased errors, latency, or unavailability for certain workloads. For the latest information from AWS, see the AWS Health Dashboard.
We continue to closely monitor Atlas deployments in ME-CENTRAL-1 and will provide additional updates if we observe any further impact to Atlas customers.
Posted Mar 01, 2026 - 14:55 UTC
Identified
Impact: Some Atlas customers with deployments in the AWS me-central-1 (United Arab Emirates) region may experience delays in cluster operations (for example, creating, scaling, or modifying clusters and infrastructure-level maintenance tasks).
Root cause: AWS is reporting connectivity and power issues affecting APIs and instances in a single Availability Zone in the me-central-1 Region, which can cause increased errors and latency for some AWS services and workflows. For the latest details from AWS, see the AWS Health Dashboard.
What you might see: - Cluster create/scale/modify operations remaining in a pending or in-progress state longer than usual - Slower completion of some maintenance and infrastructure operations in the affected region
Our actions: - Monitoring the AWS incident and Atlas fleet behavior in me-central-1
Customer action: No action is required at this time. We expect delayed operations to complete as AWS resolves the underlying issue. If you have time-sensitive changes that are blocked and need urgent assistance, please contact MongoDB Support.
Next update: We will provide updates on this page as AWS progresses mitigation or if we observe any change in impact to Atlas customers.