Atlas Stream Processing is experiencing issues in Azure - West Europe

Incident Report for MongoDB Cloud

Resolved

The issue has been resolved.
Posted Jul 10, 2026 - 01:11 UTC

Monitoring

A fix has been implemented and we are monitoring the region.
Posted Jul 10, 2026 - 00:32 UTC

Investigating

We are currently investigating an issue affecting Stream Processing Azure West Europe. User initiated commands & workloads may see intermittent failures.
Posted Jul 09, 2026 - 23:03 UTC
This incident affected: MongoDB Atlas Stream Processing.