MongoDB Cloud Manager: Some pages in Cluster Management UI are unavailable

Incident Report for MongoDB Cloud

Resolved

A fix has been implemented and deployed
Posted Mar 06, 2025 - 19:46 UTC

Identified

The issue has been identified and a fix is being implemented
Posted Mar 06, 2025 - 19:16 UTC

Investigating

We are aware of some pages in the Cloud Manager UI for managing clusters being unavailable. We've identified a fix and are working on restoring access.

Cloud Manager Admin API is unaffected

Backing cluster health and operations are unaffected.
Posted Mar 06, 2025 - 19:15 UTC
This incident affected: MongoDB Cloud.