Atlas UI Project Overview Page Infinite Loading

Incident Report for MongoDB Cloud

Resolved

This incident has been resolved.
Posted Oct 01, 2025 - 21:51 UTC

Monitoring

A fix has been deployed and is being monitored.
Posted Oct 01, 2025 - 21:19 UTC

Identified

A new component in the Project Overview page is infinitely loading. The rest of the Overview page is unaffected, and cluster health is unaffected. A fix is being worked on.
Posted Oct 01, 2025 - 18:30 UTC

Investigating

We are investigating an issue where the project overview page appears to be loading infinitely.
Posted Oct 01, 2025 - 18:12 UTC
This incident affected: MongoDB Cloud.