Issues rotating certificates for projects containing only Atlas Free and Flex clusters

Incident Report for MongoDB Cloud

Update

We are continuing to monitor for any further issues.
Posted Aug 19, 2026 - 22:00 UTC

Update

We are continuing to monitor for any further issues.
Posted Aug 19, 2026 - 21:58 UTC

Update

We are continuing to monitor for any further issues.
Posted Aug 19, 2026 - 21:57 UTC

Monitoring

We performed remediation steps on all impacted projects. We will continue to monitor for more occurrences of this issue.
Posted Aug 19, 2026 - 21:50 UTC

Identified

We have identified an issue impacting certain projects containing only Free or Flex clusters. For those clusters, TLS certificates are not being rotated correctly. This could lead to an inability to connect to your Free or Flex cluster. We are working on remediation steps.
Posted Aug 19, 2026 - 20:45 UTC
This incident affects: MongoDB Cloud.