MongoDB Cloud: Slow page loads

Incident Report for MongoDB Cloud

Resolved

This incident has been resolved.
Posted Jun 11, 2024 - 17:08 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 11, 2024 - 16:59 UTC

Investigating

We are investigating reports of slow page loads in the Atlas UI. We have no reason to believe that cluster operations or health are impacted at this time.
Posted Jun 11, 2024 - 16:52 UTC
This incident affected: MongoDB Cloud.