Atlas UI and API Periodic Unavailability

Incident Report for MongoDB Cloud

Resolved

This incident has been resolved.

Following the incident, we identified an issue that caused some internal Atlas jobs not to start as scheduled, resulting in delays to certain changes.

The issue was related to this incident "Atlas UI and API Periodic Unavailability" which has been remediated.

Customer clusters and their data were not affected; the impact was limited to the timing of control-plane operations. This jobs issue has been resolved as well.
Posted Aug 18, 2026 - 15:17 UTC

Monitoring

We have disabled the workload and are monitoring the situation
Posted Aug 18, 2026 - 15:04 UTC

Identified

We have identified a new workload that was putting more load than expected on the backing system. We are working on disabling it. Customer clusters remain unaffected.
Posted Aug 18, 2026 - 14:57 UTC

Investigating

We are investigating an issue where customers periodically cannot access the Atlas UI or utilize the API. Customer clusters are unaffected.
Posted Aug 18, 2026 - 14:10 UTC
This incident affected: MongoDB Cloud.