Delays in cluster creation and adding new cluster nodes in Azure East US 2 region

Incident Report for MongoDB Cloud

Resolved

We are no longer seeing capacity issues in Azure East US 2. This issue is now resolved.
Posted Mar 30, 2026 - 23:10 UTC

Identified

Identified: Some clusters in the Azure East US 2 region will see delays provisioning new clusters or adding additional nodes to their existing clusters due to Azure capacity constraints.

What you might see: Delays in provisioning new clusters or adding additional nodes in Azure East US 2 region.

User action: As a workaround, users can provision clusters in other Azure regions.
Posted Mar 30, 2026 - 21:47 UTC
This incident affected: MongoDB Cloud.