Degraded Performance: Atlas UI and API Operations
Incident Report for MongoDB Cloud
Resolved
We have resolved the issue and all systems are operating normally
Posted May 02, 2024 - 01:26 UTC
Monitoring
We have identified the issue and implemented a fix.

Users should experience normal API response times and can access the UI once again. We are actively monitoring to ensure the system remains stable.
Posted May 02, 2024 - 01:16 UTC
Update
We are seeing degraded performance with our UI and API operations. Users may experience longer page load times as well as delays in responses from API calls.

Users attempting to login to Atlas, Cloud Manager, the Support Portal, or University may encounter errors.

Customers may experience delays applying updates to their cluster.

We are continuing to investigate the issue.
Posted May 02, 2024 - 01:00 UTC
Update
We are seeing degraded performance with our UI and API operations. Users may experience longer page load times as well as delays in responses from API calls.

Users attempting to login to Atlas, Cloud Manager, the Support Portal, or University may encounter errors.

Customer clusters appear unaffected at this time.

We are actively investigating the issue.
Posted May 02, 2024 - 00:46 UTC
Investigating
We are seeing degraded performance with our UI and API operations. Users may experience longer page load times as well as delays in responses from API calls.

We are actively investigating the issue.
Posted May 02, 2024 - 00:33 UTC
This incident affected: MongoDB Cloud and MongoDB Support Portal.