MongoDB Atlas: Invoice summaries are not loading
Incident Report for MongoDB Cloud
Resolved
This incident has been resolved.
Posted May 06, 2024 - 17:54 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 06, 2024 - 17:43 UTC
Identified
We have identified an issue where invoice summaries in the billing overview page and the individual invoice pages are not loading. This also affects PDF and CSV downloads of invoices.
Posted May 06, 2024 - 17:19 UTC
This incident affected: MongoDB Cloud.