Excessive Project Maintenance Notifications in some Atlas projects

Incident Report for MongoDB Cloud

Resolved

This incident has been resolved.
Posted Aug 31, 2025 - 09:05 UTC

Monitoring

Some MongoDB Atlas Customers have received duplicate maintenance notifications in projects with Maintenance Windows[0] configured.

We have implemented a mitigation and are monitoring results.

[0] https://www.mongodb.com/docs/atlas/tutorial/cluster-maintenance-window/
Posted Aug 31, 2025 - 00:55 UTC
This incident affected: MongoDB Cloud.