Elevated failures from GCP

Incident Report for MongoDB Cloud

Resolved

This incident has been resolved.
Posted Jun 12, 2025 - 23:41 UTC

Monitoring

GCP API errors have dropped down to normal levels again. Cluster modifications should be unblocked. We're continuing to monitor the situation
Posted Jun 12, 2025 - 21:24 UTC

Update

Atlas Data Federation and Online Archive on GCP may experience intermittent query failures and processing delays.
Posted Jun 12, 2025 - 21:15 UTC

Identified

GCP has created a status post here https://status.cloud.google.com/. You can follow that for more details on the incident.
Posted Jun 12, 2025 - 19:25 UTC

Investigating

We've identified an issue with increased 503's coming from GCP. We are working directly with the cloud provider to identify the root cause. Cluster health is unaffected. GCP Cluster modification will be delayed at this time.

New cluster creation on any cloud provider may be delayed due to CAPTCHA failures.
Posted Jun 12, 2025 - 18:38 UTC
This incident affected: MongoDB Cloud.