Atlas Cluster Scheduled Operations Delays
Incident Report for MongoDB Cloud
Resolved
The issue has been resolved.
Posted Oct 18, 2023 - 18:54 UTC
Monitoring
The issue has been resolved. We are actively monitoring.
Posted Oct 18, 2023 - 17:42 UTC
Identified
We are experiencing an issue that may result in delays to some scheduled cluster operations such as backups and planned maintenance.

User-driven / requested change operations are not impacted.
Posted Oct 18, 2023 - 16:40 UTC
This incident affected: MongoDB Cloud.