Intermittent 503 Errors on Atlas Admin API and Automation Tooling

Incident Report for MongoDB Cloud

Update

We continue to monitor our systems for intermittent spikes in 503 HTTP errors following our deployed fix. We will provide another update tomorrow by 3 PM UTC.
Posted Mar 26, 2026 - 19:12 UTC

Monitoring

The team has identified the root cause of intermittent spikes of HTTP 503 errors and has applied a fix.
Posted Mar 25, 2026 - 23:39 UTC

Investigating

We are currently investigating intermittent spikes of HTTP 503 errors affecting Atlas control plane operations performed via the Atlas Admin API and automation tooling such as Terraform. Impacted requests typically fail for a short period and succeed on retry. Atlas database connectivity and data plane operations remain healthy.

Our engineering teams are working to resolve the issue with high urgency and to prevent recurrence. Customers encountering 503 responses are advised to retry failed Admin API and Terraform operations with appropriate retry logic and backoff while we continue our investigation.
Posted Mar 25, 2026 - 21:31 UTC
This incident affects: MongoDB Cloud.