Issue affecting stream processing within the AWS US-EAST-1 region

Incident Report for MongoDB Cloud

Resolved

At approximately 10:30 AM CT, we identified an issue affecting stream processing within the AWS US-EAST-1 region. As of now, normal operations have resumed. We have initiated a full investigation to determine the root cause and prevent future recurrence.
Posted Mar 11, 2026 - 20:10 UTC
This incident affected: MongoDB Atlas Stream Processing.