Some Atlas Cluster Operations Delayed

Incident Report for MongoDB Cloud

Resolved

This incident has been resolved.
Posted Oct 06, 2025 - 23:19 UTC

Monitoring

The system is in healthy state and cluster operations are no longer delayed. We are monitoring for any residual effects.
Posted Oct 06, 2025 - 22:12 UTC

Identified

The system had unusually high load causing delays in operations. The issue has been identified and we are working on fix.
Posted Oct 06, 2025 - 21:42 UTC

Update

We are continuing to investigate the issue. Atlas Cluster operations (including metrics ingestion) are delayed but underlying cluster health is unaffected.
Posted Oct 06, 2025 - 20:48 UTC

Investigating

Some Atlas cluster operations are delayed. This includes cluster operations and metrics ingestion. We are currently investigating the issue.
Posted Oct 06, 2025 - 19:33 UTC
This incident affected: MongoDB Cloud.