Microsoft Azure Incident: Delayed Cluster Operations
Incident Report for MongoDB Cloud
Resolved
This incident has been resolved.
Posted Jun 15, 2024 - 04:25 UTC
Update
Microsoft Azure updated the Service Health Dashboard to indicate they confirm the infrastructure issue is resolved but continue to monitor before declaring full mitigation.

We are monitoring Atlas cluster deployments for any residual effects and will mitigate any issues if necessary.
Posted Jun 15, 2024 - 03:20 UTC
Update
Microsoft Azure updated the Service Health Dashboard to indicate they expect full mitigation within the next hour.

We will continue to monitor the service issue and provide updates when possible.
Posted Jun 15, 2024 - 02:56 UTC
Update
Microsoft Azure updated the Service Health Dashboard to indicate Azure Resource Manager errors in East US 2 region may also be experienced globally for resources hosted on that service.

They are working on a mitigation strategy for this incident.

We will continue to monitor the service issue and provide updates when possible.
Posted Jun 14, 2024 - 23:35 UTC
Monitoring
We are monitoring the service issue.
Posted Jun 14, 2024 - 22:02 UTC
Investigating
Microsoft Azure is experiencing an issue with the Azure Resource Manager for Virtual Machines in East US 2 region. As a result, users may experience delays creating, updating or deleting clusters in this region.

Further incident details may be found in the Service Health Dashboard in your Microsoft Azure Portal.
Posted Jun 14, 2024 - 22:02 UTC
This incident affected: MongoDB Cloud.