MongoDB Atlas BI Connector: Connections and queries fail

Incident Report for MongoDB Cloud

Identified

We have identified the issue affecting the Business Intelligence (BI) Connector in MongoDB Atlas for Government. We are working on a fix. While no workaround exists, data remains accessible to MongoDB clients. Affected users will not be able to connect to their clusters' BI Connectors.

Cluster health is unaffected.
Posted Apr 17, 2026 - 20:24 UTC

Investigating

We are currently investigating reports in MongoDB Atlas for Government that the Business Intelligence Connector (BI Connector) is failing. Affected users will have issues connecting to and querying their BI Connectors. No workaround has been identified at this time.

Underlying cluster health is not affected.
Posted Apr 17, 2026 - 17:03 UTC
This incident affects: MongoDB Atlas for Government.