Cluster page is currently unavailable in the Atlas UI

Incident Report for MongoDB Cloud

Resolved

This incident has been resolved.
Posted Feb 20, 2025 - 21:26 UTC

Monitoring

We have identified the issue and the cluster page in the Atlas UI is now available. We continue to monitor the system and ensure there are no residual issues.
Posted Feb 20, 2025 - 17:52 UTC

Investigating

We are investigating an issue with loading the clusters page in the Atlas UI
Posted Feb 20, 2025 - 17:48 UTC
This incident affected: MongoDB Cloud.