MongoDB Atlas: Atlas UI loading slowly

Incident Report for MongoDB Cloud

Resolved

We have identified and resolved the issue. Atlas UI will load without a delay now.
Posted Feb 13, 2026 - 07:55 UTC

Investigating

We are currently investigating reports of the slow loading of the Atlas web UI.
Posted Feb 13, 2026 - 07:20 UTC
This incident affected: MongoDB Cloud.