Cluster connectivity issues in Azure westus

Incident Report for MongoDB Cloud

Resolved

Azure has rolled out mitigation for the networking incident affecting the West US region and recovery is complete.
Posted Jul 23, 2026 - 20:28 UTC

Update

Azure is rolling out a mitigation for the ongoing networking incident affecting the West US region, and we are seeing signs of recovery. Some Atlas clusters hosted in Azure West US may continue to experience intermittent connectivity issues, including failures connecting to clusters, issues with communication between cluster nodes, nodes appearing down, and delays to cluster modifications. We are monitoring recovery closely and will provide additional updates as more information becomes available.
Posted Jul 23, 2026 - 18:54 UTC

Update

We are aware of an ongoing Azure networking incident affecting the West US region. Some Atlas clusters hosted in Azure West US may experience intermittent connectivity issues, including failures connecting to clusters, issues with communication between cluster nodes, nodes appearing down, and delays to cluster modifications. Azure is investigating the issue and evaluating mitigation options. We will provide additional updates as more information becomes available.
Posted Jul 23, 2026 - 18:26 UTC

Identified

Azure has confirmed that there are networking issues in the westus region. Please follow the official azure status post for more detailed updates https://azure.status.microsoft/en-us/status
Posted Jul 23, 2026 - 16:38 UTC

Investigating

We are currently investigating an issue with Azure clusters in westus region. Please refer to the azure status post here for more information https://azure.status.microsoft/en-us/status.
Posted Jul 23, 2026 - 16:21 UTC
This incident affected: MongoDB Cloud.