AWS cluster backup and restore operations are failing

Incident Report for MongoDB Cloud

Resolved

This incident has been resolved. AWS clusters should no longer encounter errors during backup and restore.
Posted Jul 02, 2026 - 11:09 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 02, 2026 - 10:50 UTC

Investigating

We are currently investigating the issue where AWS cluster backup and restores are failing. This includes exports and manual downloads as well as restoring to another cluster.

We are also investigation potential impact to other operations on AWS clusters such as modifying instance size.
Posted Jul 02, 2026 - 10:45 UTC
This incident affected: MongoDB Cloud.