Impaired Cluster Operations due to Lets Encrypt Service Degradation

Incident Report for MongoDB Cloud

Resolved

Let's Encrypt services have returned back to normal. Cluster operations have now returned to normal.
Posted Jul 02, 2026 - 23:36 UTC

Monitoring

We are currently monitoring the status of Lets Encrypt after an issue with their API. Tenant clusters and Atlas for Government clusters will experience delays in provisioning due to Lets Encrypt service degradation.
Posted Jul 02, 2026 - 23:09 UTC
This incident affected: MongoDB Cloud and MongoDB Atlas for Government.