Impaired Cluster Operations due to Lets Encrypt Outage

Incident Report for MongoDB Cloud

Resolved

This incident has been resolved.
Posted May 08, 2026 - 22:07 UTC

Update

Lets Encrypt is now reporting as healthy. We will continue monitoring as cluster operations return to a healthy state.
Posted May 08, 2026 - 21:39 UTC

Monitoring

Cluster operations are currently impaired due to issues with Lets Encrypt. We are actively monitoring the situation as more updates come in.
Posted May 08, 2026 - 19:33 UTC
This incident affected: MongoDB Cloud and MongoDB Atlas for Government.