DNS Resolution failures for public IP addresses within 31.89.0.0/24

Incident Report for MongoDB Cloud

Resolved

The DNS records have been backfilled and clusters that had these IP addresses should be recovered.
Posted Feb 13, 2026 - 17:57 UTC

Identified

We have identified the root cause and are working on backfilling those records with AWS support.

We have also disabled that ip range for new clusters so moving forward this issue will not be hit for new AWS clusters.
Posted Feb 13, 2026 - 16:42 UTC

Investigating

We are investigating an issue with DNS resolution for public IP addresses within 31.89.0.0/24. We are engaging with AWS support to remediate the situation.
Posted Feb 13, 2026 - 16:11 UTC
This incident affected: MongoDB Cloud.