Impaired Cluster Operations due to Lets Encrypt Outage

Incident Report for MongoDB Cloud

Resolved

We've confirmed that Lets Encrypt has returned to normal operations. Cluster operations are now back to normal.
Posted Jul 02, 2026 - 21:06 UTC

Monitoring

We are currently monitoring the status of Lets Encrypt. Tenant clusters and Atlas for Government clusters will experience delays in provisioning due to Lets Encrypt service degradation.
Posted Jul 02, 2026 - 19:34 UTC
This incident affected: MongoDB Cloud and MongoDB Atlas for Government.