Metrics ingestion delays and delayed cluster operations

Incident Report for MongoDB Cloud

Resolved

This incident has been resolved.
Posted Oct 07, 2025 - 20:03 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 07, 2025 - 19:32 UTC

Identified

We have identified the cause of the issue and have taken corrective actions. We are monitoring the impact of those mitigations. During this time Host Down alerts, metrics, and some Atlas Cluster Operations may still be delayed or missing.
Posted Oct 07, 2025 - 17:44 UTC

Update

We are continuing to investigate the issue. During this time Host Down alerts will not fire and metrics may be missing or delayed for Atlas and Cloud Manager Clusters. Cluster operations may also be delayed.
Posted Oct 07, 2025 - 15:45 UTC

Investigating

We are currently investigating a delay in our metric ingestion pipeline. Customers may see delays in cluster operations.
Posted Oct 07, 2025 - 13:42 UTC
This incident affected: MongoDB Cloud.