Delayed cluster configuration affecting free and flex users

Incident Report for MongoDB Cloud

Resolved

This incident has been resolved.
Posted Jul 29, 2026 - 19:37 UTC

Monitoring

We have seen errors subsiding and cluster configurations for free and flex customers should be operating normally again.
Posted Jul 29, 2026 - 19:31 UTC

Identified

We have identified the root cause and are rolling out a configuration change to remediate the delayed cluster configuration changes.
Posted Jul 29, 2026 - 19:06 UTC

Investigating

We are investigating an issue with cluster configuration updates getting delayed for a subset of users on free and flex tiers. Cluster access is unaffected.
Posted Jul 29, 2026 - 18:55 UTC
This incident affected: MongoDB Cloud.