Intermittent Restore Failures on Atlas

Incident Report for MongoDB Cloud

Resolved

While some restores from snapshots stored in Azure or GCP may have taken longer to start than usual, there have been no complete failures observed. Cluster health was unaffected during this time.
Posted Jun 14, 2025 - 17:07 UTC

Update

We are continuing to work with GCP support to remediate the situation
Posted Jun 14, 2025 - 15:02 UTC

Identified

We've identified the issue and are working with GCP support to resolve the situation.
Posted Jun 14, 2025 - 12:12 UTC

Investigating

We are investigating a situation where backup restores are intermittently failing.
Posted Jun 14, 2025 - 10:21 UTC
This incident affected: MongoDB Cloud.