MongoDB Atlas: Email notifications may be failing

Incident Report for MongoDB Cloud

Resolved

This incident has been resolved. Email notifications are being sent successfully.
Posted Mar 02, 2026 - 16:28 UTC

Investigating

We are currently investigating this issue.
Some users may not be receiving emails from MongoDB. We are looking into the cause and will provide an update as soon as we know more.
Posted Mar 02, 2026 - 15:50 UTC
This incident affected: MongoDB Cloud.