Authentication failures when running search queries for some clusters

Incident Report for MongoDB Cloud

Resolved

This incident has been resolved.
Posted May 24, 2026 - 02:05 UTC

Monitoring

We have resolved the issue for all impacted clusters. We continue to monitor the fleet for any residual impact.
Posted May 24, 2026 - 00:14 UTC

Identified

We have identified the root cause of the search query failures and are working on a mitigation for impacted clusters. Clusters with dedicated search nodes are unaffected. Some clusters with colocated search nodes may see search query failures.
Posted May 23, 2026 - 20:14 UTC

Investigating

We are investigating an issue impacting some clusters that causes search queries to fail with authentication failures.
Posted May 23, 2026 - 19:48 UTC
This incident affected: MongoDB Cloud and MongoDB Atlas Search.