Elevated errors for cluster creation on AWS

Incident Report for MongoDB Cloud

Resolved

This incident has been resolved.
Posted Feb 12, 2026 - 23:10 UTC

Monitoring

We have implemented the fix. Customers will now be able to create new clusters on AWS.
Posted Feb 12, 2026 - 23:08 UTC

Identified

We have identified the root cause and are implementing a fix to remediate the situation
Posted Feb 12, 2026 - 23:00 UTC

Investigating

We are currently investigating elevated errors for customers attempting to create a cluster on AWS
Posted Feb 12, 2026 - 22:10 UTC
This incident affected: MongoDB Cloud.