Atlas is experiencing issues with issuing certificates from Lets Encrypt

Incident Report for MongoDB Cloud

Resolved

This incident has been resolved.
Posted Sep 11, 2026 - 03:51 UTC

Monitoring

Atlas is seeing elevated errors rates of certificate issuance due to a Let's Encrypt outage (https://letsencrypt.status.io/pages/incident/55957a99e800baa4470002da/6aa35c1d892d7304f2747e01). Free and flex tier cluster provisioning may be delayed.
Posted Sep 11, 2026 - 02:01 UTC

Investigating

We are currently investigating issues related to certificate issuing failures with Lets Encrypt. Free and Flex cluster provisioning may be delayed.
Posted Sep 11, 2026 - 01:28 UTC
This incident affected: MongoDB Cloud and MongoDB Atlas for Government.