Users unable to add new PayPal payment address
Incident Report for MongoDB Cloud
Postmortem

PayPal users in all jurisdictions can now add their PayPal accounts to MongoDB Cloud. We have taken steps with upstream providers to ensure that this issue does not recur including special treatment for MongoDB’s accounts.

Posted Oct 19, 2023 - 16:12 UTC

Resolved
This incident has been resolved. While users will no longer see errors upon entering PayPal details, US-based users will not be able to add or modify PayPal details. We are working with our upstream providers to address this.
Posted Oct 16, 2023 - 15:51 UTC
Identified
We have identified an issue adding new PayPal accounts to MongoDB Cloud for payment. Users are encouraged to use other payment methods or wait for this issue to be resolved. We are investigating root causes at this time.
Posted Oct 13, 2023 - 15:28 UTC