MongoDB Cloud: PayPal charges may fail
Incident Report for MongoDB Cloud
Resolved
This incident has been resolved.
Posted Jul 05, 2024 - 15:30 UTC
Investigating
We have received higher-than-normal reports of failed PayPal transactions. Affected users will have been notified via email and may see a WARNING state on their Organization. This mostly has impacted Organizations with billing addresses outside of the USA.

We are investigating with our upstream partners to correct the issue.
Posted Jul 02, 2024 - 15:57 UTC
This incident affected: MongoDB Cloud.