MongoDB Atlas: Activation Code redemptions may fail

Incident Report for MongoDB Cloud

Resolved

This incident has been resolved. During this time, users may have also had issues activating self-service support plans. We encourage any affected users to sign up again.
Posted Nov 19, 2025 - 18:54 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 19, 2025 - 18:22 UTC

Identified

We have identified an issue redeeming Activation Codes in both MongoDB Atlas and MongoDB Atlas for Government. Affected users will have an error when trying to apply their Activation Codes which may show as the "save" button disappearing and the subscription not being applied.

There is no workaround at this time. Please try again after this issue clears.
Posted Nov 19, 2025 - 17:55 UTC
This incident affected: MongoDB Cloud and MongoDB Atlas for Government.