Impaired Cluster operations in AWS me-central-1 and AWS me-south-1

Incident Report for MongoDB Cloud

Update

We are continuing to monitor for any further issues.
Posted Sep 03, 2026 - 16:47 UTC

Monitoring

Please follow the original status post for updates on AWS me-central-1 and AWS me-south-1 issues.
Posted Sep 03, 2026 - 16:44 UTC
This incident affects: MongoDB Cloud.